
























	



<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">




<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US">
	















	







<head>
	<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />
	
	<title>
		Ai EasyChill 3 Cu Ft -25°C Upright Freezer UL 110V
	</title>

	
	<meta name="description" content="Ai EasyChill 3 Cu Ft -25°C Upright Freezer UL 110V"/>

	
	<meta name="keywords" content="Ai EasyChill 3 Cu Ft -25°C Upright Freezer UL 110V Covid-19 Vaccines"/>
	
	
	<meta name="google-site-verification" content="YBMS8pVdEXb2aOwL4T5xmJq6uc7JeSWL1zOgM5jguI8"/><meta name="y_key" content="391d4148ef81c47f"/><meta name="msvalidate.01" content="A006AD751FC5E093C8764778424CC9AB"/>

	
	<link rel="icon" href="/images/1468163246635-411275160.gif?ver=12897610" type="image/gif" /><link rel="shortcut icon" href="/images/1468163246635-411275160.gif?ver=12897610" type="image/gif" />

	
	<link rel="canonical" href="https://www.acrossinternational.com/Ai-EasyChill-3-Cu-Ft-25C-Upright-Freezer-UL-115V-E03110.htm" />
	
	
	
	
	
	
	












	




	














<link rel="stylesheet" type="text/css" href="/static/styles/pages/sf.desktop.head.css?v=20201214-105212"/>


<script type="text/javascript" src="/static/scripts/pages/sf.desktop.head.js?v=20201214-105212"></script>
<script type="text/javascript">/*<![CDATA[*/var QSC=QSC||{};QSC.env={getVersion:function(){return "3.0.34.107_20201214-105212"},getStaticScriptUrl:function(){return "/static/"},getStaticStyleUrl:function(){return "/static/"},getStaticImageUrl:function(){return "/static/"},getStaticMediaUrl:function(){return "/static/"},getNonCdnStaticScriptUrl:function(){return "/static/"},getNonCdnStaticStyleUrl:function(){return "/static/"},getNonCdnStaticImageUrl:function(){return "/static/"},getNonCdnStaticMediaUrl:function(){return "/static/"},getNonCdnStaticScriptRegex:function(){return "^.*tiny_mce\.js"},getNonCdnStaticStyleRegex:function(){return ""},getNonCdnStaticImageRegex:function(){return "swfupload\.swf"},getNonCdnStaticMediaRegex:function(){return "^.*/channel\.html$"},getFastBallPageUrl:function(){return ""},getFastBallDomain:function(){return ""},getPrivateLabelId:function(){return 0},starfieldUI:{getScriptUrl:function(){return "https://img3.wsimg.com/starfield/curl/v1.4/curl.js"},isHelpSidebarEnabled:function(){return false}},isLoggedIn:function(){return false},currency:{getSymbol:function(){return "$"},getSymbolPosition:function(){return "0"},getFormatBig:function(){return "1,000,000.00"},getFormatSmall:function(){return "0.00"}}};/*]]>*/</script>






  
	<link rel="stylesheet" type="text/css" href="/static/styles/common/layout_contemp.css?v=20201214-105212"/>
	<!--[if IE]>
	    <link rel="stylesheet" type="text/css" href="/static/styles/common/common_ie6.css?v=20201214-105212"/>
	<![endif]-->
	<link rel="stylesheet" type="text/css" href="/static/styles/common/category_8.css?v=20201214-105212"/>
	<link rel="stylesheet" type="text/css" href="/static/styles/common/product_3.css?v=20201214-105212"/>
	<link rel="stylesheet" href="/qsctemplates/Theme643/theme.css" type="text/css"/>
	<link rel="stylesheet" href="/qsctemplates/Theme643/color_1.css" type="text/css"/>
	<link rel="stylesheet" href="/qsctemplates/Theme643/app3/theme.css" type="text/css"/>
	<link rel="stylesheet" href="/qsctemplates/Theme643/app3/color_1.css" type="text/css"/>
  
  









  
  
  



  <link rel="stylesheet" type="text/css" href="/static/styles/common/jcarousel.css?v=20201214-105212"/>





  <link rel="stylesheet" type="text/css" href="/static/styles/common/jcarousel-categories-ext.css?v=20201214-105212"/>



  <link rel="stylesheet" type="text/css" href="/static/styles/common/jcarousel-associatedProducts-ext.css?v=20201214-105212"/>



  <script type="text/javascript" src="/static/scripts/jquery.jcarousel.pack.js?v=20201214-105212"></script>
  <script type="text/javascript" src="/static/scripts/QSC.apps.jCarousel.circularHelper.js?v=20201214-105212"></script>








	
		<link rel="stylesheet" href="/custom_12897610.css" type="text/css"/>
	
	



	
	



	
	










<!--[if lte IE 6]>
<script type="text/javascript" src="/static/scripts/subnav.js?v=20201214-105212"></script>
<![endif]-->













	
	
	
		
<link rel="stylesheet" type="text/css" href="/static/styles/pages/sf.desktop.product.css?v=20201214-105212"/>

	

	 

</head>

	















	









	
	
	
	
		<body class="desktop qsc category_12 product_3">
		












	




	











<div class="sf_outer_wrapper">
	<div class="sf_region1">
		














	</div>
	<div class="sf_extra1"><span></span></div>
	<div class="sf_wrapper">
		<div class="sf_region2">
			













  
    <div class="sf_navigation">
      
        
          
          
             
            












	




	






 


  
	<div class="widget main_nav">
		<h3 class="widget_header"><span>Main Navigation</span></h3>
		<div class="widget_content">
		












	
		
		
			
			
		
	
	
	
	<ul class="nav" id="Nav1" >
	
		
		
		
		
		
		<li class="sf_first_nav_item" >
			<a href="/aboutus.sc"  >
				About Us</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="/contactus.sc"  >
				Contact Us</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="/main.sc"  >
				Tools</a>
			
				












	
		
		
			
			
		
	
	
	
	<ul class="subnav"  >
	
		
		
		
		
		
		<li class="sf_first_nav_item_subnav" >
			<a href="https://aivacovens.com/wp-content/uploads/AcrossInternationalW9.pdf" target="_blank" >
				W9 Form</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="https://www.unitconverters.net" target="_blank" >
				Unit Converter</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="https://aivacovens.com/wp-content/uploads/Melting-Points.pdf" target="_blank" >
				Metals Melting Point</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="https://en.wikipedia.org/wiki/Mesh_%28scale%29" target="_blank" >
				Particle Size Comparison</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="https://aivacovens.com/wp-content/uploads/NEMA_Plugs.pdf" target="_blank" >
				NEMA Configurations</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="https://en.wikipedia.org/wiki/AC_power_plugs_and_sockets" target="_blank" >
				Electrical Outlet</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="/sitemap.htm"  >
				Site Map</a>
			
		</li>
	
		
		
		
		
		
		<li class="sf_last_nav_item_subnav" >
			<a href="/help.sc" target="_blank" >
				Help</a>
			
		</li>
	
	</ul>


			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="/login.sc"  >
				Sign In</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="/register.sc"  >
				Register</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="/termsandconditions.sc"  >
				Terms and Conditions</a>
			
		</li>
	
		
		
		
		
		
		<li  >
			<a href="https://www.acrossinternational.com/contactus.sc#RequestQuote"  >
				Request a Quote</a>
			
		</li>
	
		
		
		
		
		
		<li class="sf_last_nav_item" >
			<a href="/viewcart.sc"  >
				Shopping Cart</a>
			
		</li>
	
	</ul>


		</div>
	</div>
  
  


          
        
      
    </div>
  


		</div>
		<div class="sf_extra10"><span></span></div>
		<div class="sf_header_wrapper">
			<div class="sf_extra2"><span></span></div>
			<div class="sf_region3">
				













  
    <div class="sf_search">
      
        
          
          
             
            












	




	







  
  
    
	<div class="widget quick-search">
		<h3 class="widget_header"><span>Quick Search</span></h3>
		<div class="widget_content">
			<form id="searchQuickForm" method="get" action="/searchquick-submit.sc">
				<div class="form_item">
					<input type="text" name="keywords" value="" id="searchtext" class="input" /> 				
				</div>
				<div class="form_button">
					<input type="submit" value="Go!" class="quick-search-button btn" />
				</div>
			</form>
			<a href="/searchadvanced.sc">Advanced Search</a>
		</div>
	</div>
  
  



          
        
      
    </div>
  
    <div class="sf_main_header">
      
        
          
          
             
            












	




	







	
	
		<div id="header-content">
			








  

<a href="main.sc" id="logo"><span class="qsc-site-logo"><img src="/images/AiBlueLogo-tiny(3).gif" alt="Across International" /></span></a>
<div class="titles">
  <div class="company-name"><span class="qsc-site-companyname">Across International</span></div>
  <div class="slogan"><span class="qsc-site-slogan">Material Processing Equipment</span></div>
</div>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-22577123-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('set', 'allow_ad_personalization_signals', false);
  gtag('js', new Date());

  gtag('config', 'UA-22577123-1');
</script>


<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '2852112544813530');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=2852112544813530&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-22577123-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-22577123-1');
</script>



<!-- Global site tag (gtag.js) - Google AdWords: 1031857376 -->
<script async src="https://www.googletagmanager.com/gtag/js?id=AW-1031857376"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'AW-1031857376');
</script>




<script>
  gtag('config', 'AW-1031857376/iJ-ZCMKSzn8Q4MmD7AM', {
    'phone_conversion_number': '888-988-0899'
  });
</script>

<script>
window.addEventListener('load',function(){
if(window.location.pathname=="/checkoutaddresses-submit.sc"){

 gtag('event', 'conversion', {
      'send_to': 'AW-1031857376/YUaoCOexh9wBEODJg-wD',
      'transaction_id': ''
  });
}

})


</script>
		</div>
	



          
        
      
    </div>
  


			</div>
			<div class="sf_extra3"><span></span></div>
		</div>
		<div class="sf_extra4"><span></span></div>
		<div class="sf_region4">
			














		</div>
		<div class="sf_extra5"><span></span></div>
		<div class="sf_region5">
			














		</div>
		<div class="sf_extra6"><span></span></div>
		<div class="sf_extra11"><span></span></div>
		<div class="sf_main_wrapper">
			<div class="sf_main">
				<div class="sf_region6">
					













  
    <div class="sf_content">
      
        
          
            












	




	















            












	




	












            












	




	











            












	




	









	<div class="breadcrumb page-block" id="breadcrumbs">
		
		
			
			
			
				
				
                    <a href="/main.sc" class="breadcrumb home">Our Products</a>
				
				
			
			
		
			
			
				&nbsp;&gt;&gt;&nbsp;
			
			
				
					
						
							Ai EasyChill 3 Cu Ft -25°C Upright Freezer UL 115V
						
						
					
				
				
				
			
			
		
	</div>




            
            
            
              
              
                            
              
              
                
                
                
                
                
                
                                
              
              
            
            <div class="main-content">
              
                <h1>Ai EasyChill 3 Cu Ft -25°C Upright Freezer UL 115V</h1>
              
     		  












	




	





















  
  
    
  



  









<div class="product-page">
    
		
		
		
			<div class="product-detail">
	            					
				<div class="product-primary">
					






  
  


                    
                      
                      
                                            
                      
                        <div class="imageanddetails">
                          
























<div class="product-image">
  
  
    
    
    

		
		<script type="text/javascript" src="/static/scripts/productFilmstrip.js?v=20201214-105212"></script>
		<div class="filmstrip-preview">
			
			<span id="zoomImageURL" style="display:none; visibility:hidden;">/images/E03-lh-open.jpg</span>
			<table cellpadding="0" cellspacing="0">
				<tr>
					<td>
						
						<img style="cursor:pointer; padding:0;" src="/images/1612992460917-35386614.jpeg" alt="Laboratory Freezers" id="filmstripPreview" onclick="QSC.page.current().showZoomPopup(document.getElementById('filmstripPreview'))" />
					</td>
				</tr>
			</table>
		</div>

		<div class="clicktozoom" style="padding:3px 0" onclick="QSC.page.current().showZoomPopup(document.getElementById('filmstripPreview'))">
			
				Click To Enlarge
			
		</div>

		<div class="filmstrip-thumbnails">
			<table>
				
					
					
					
					
					
					

					<tr>
					<td>
						<a href="#" id="useCode_F1" onclick="showPreview('/images/1612992460917-35386614.jpeg','/images/E03-lh-open.jpg'); return false;">
							<img width="32" height="30" class="fst-img"  src="/images/1612992459858-1668777277.jpeg"/>
						</a>
					</td>
					
				
					
					
					
					
					
					

					
					<td>
						<a href="#" id="useCode_F2" onclick="showPreview('/images/16129924595511832167086.jpeg','/images/E03-lh-close.jpg'); return false;">
							<img width="24" height="32" class="fst-img"  src="/images/1612992458876-630765503.jpeg"/>
						</a>
					</td>
					
				
					
					
					
					
					
					

					
					<td>
						<a href="#" id="useCode_F3" onclick="showPreview('/images/16129924585921988385869.jpeg','/images/E03-lh-side.jpg'); return false;">
							<img width="28" height="32" class="fst-img"  src="/images/1612992458236272338221.jpeg"/>
						</a>
					</td>
					
				
					
					
					
					
					
					

					
					<td>
						<a href="#" id="useCode_F4" onclick="showPreview('/images/16107199056751877330375.gif','/images/AiUL-EasyChill.gif'); return false;">
							<img width="22" height="32" class="fst-img"  src="/images/1610719905853487697658.gif"/>
						</a>
					</td>
					</tr>
				
			</table>
		</div>
    
  
</div>
                          






<div class="product-details">
	<ul>
		
			<li><em>Item #:</em> E03.110</li>
		
		
        
		
		
	</ul>
</div>

						  


<div id="ratingDistribution">
	









  
  
  
  
    
    
    	
    		
      
				<a href="javascript:void(0)" onclick="QSC.page.current().getRatingsReviews().writeReview()" class="rating-container no-reviews">Be the first to write a review</a>
			
			
			
		
          
	
	
	
    
  
  


</div>



                          







  
    
    
      <div class="product-share">
        








<!-- AddThis Button BEGIN -->

  
  
  
  
    <div class="addthis_toolbox addthis_default_style">
      <a class="addthis_counter addthis_pill_style"></a>
    </div>
  

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js"></script>
<!-- AddThis Button END -->
      </div>
    
    	

                        </div>
                      
                                            
                      
                                            
                      
                    
					






					






					










	

<div class="product-options">
	<form id="addToCartForm" method="post" action="/addtocart.sc">
		<input type="hidden" name="productId" value="1426" />
		<input type="hidden" name="configOptionKey" value="" />
		<table border="0" class="product-options-table">
			
			<tr>
				<td>&#160;</td>
				<td class="required">
					* Marked fields are required.
				</td>
			</tr>
			
			
				
					
						
						
			<tr>
				<td class="label">
				  <label for="108">
					<em>Delivery liftgate service
						<span class="required">*</span>
					</em>
			      </label>
				</td>
				
				<td class="field">
				
					
					
					
						<select name="selectedOption(108)" id="selectedOption_108_"><option value="">Select</option>
							
								<option value="I do not need liftgate service"  >
									I do not need liftgate service
									
								</option>
							
								<option value="Yes I need liftgate service"  >
									Yes I need liftgate service
									
										(+$35.00)
									
								</option></select>
					
				
				</td>
			</tr>
					
				
			

			
			<tr>
				<td class="label">
					<em>Qty<span class="required">*</span></em>
				</td>
				<td class="field">
					<input type="text" name="quantity" size="3" value="1" />
				</td>
			</tr>
			
			
			
				
				
				<tr>
					<td class="label">
						<em>Price</em>
					</td>
					<td class="field">
						<span id="listPrice" class="price list">$1,590.00</span>
					</td>
				</tr>
				
			

			
			

			
			<tr id="adjustedPriceItem" class="price adj hidden">
				<td class="label">
					<em>Adjusted Price</em>
				</td>
				<td class="field">
					<span id="adjustedPrice" class="price ">$1,590.00</span>
				</td>
			</tr>

			
			
			
			
			
			
				<tr class="available-quantity"
					
					style='display:none'
					
				>
					<td class="label">
						<em># Available</em>
					</td>
					<td class="field">
						<span id="prodAvailQty"></span>
					</td>
				</tr>

		
			<tr>
				<td colspan="2" class="label">
					This item ships freight.
				</td>
			</tr>
		
			
			
			<tr class="buynow">
				<td class="label">
					<em><!-- fmt:message key="product.addtocart.prefix"/ --></em>
				</td>
				<td class="field">
					<input type="submit" name="submit" value="Add To Cart" class="btn btn-add-to-cart" />
				</td>
			</tr>
			
		</table>
	</form>
</div>

				</div>
				<div class="product-secondary">
					



<div class="product-description ">
	<div class="qsc-html-content">
<p style="text-align: center;"><img alt="" height="89" src="media/Ai-LogoVector (1).gif" width="250" /></p>
<p style="text-align: center;"><img alt="" src="media/E03-lh-close.jpg" /><br />&nbsp;</p>
<p><span style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small; color: #000000;" face="Tahoma" size="2">The new Ai EasyChill series -25&deg;C freezers is perfect for small to large storage of sample and products<span style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small; color: #000000;" face="Tahoma" size="2">. Our unique compressor design offers you speedy cooling and great temperature uniformity inside the chamber.</span></span></p>
<p><span style="font-size: small;"><strong><span style="color: #000000;">Features</span></strong></span></p>
<div style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline; color: #666666; font-family: Arial, Helvetica, FreeSans, sans-serif; font-size: 11px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-align: justify; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px; background-color: #ffffff;">
<ul style="margin: 1.12em 0px 1.12em 40px; padding: 0px 0px 0px 20px; border: 0px; outline: 0px; vertical-align: baseline; list-style: disc;">
<li style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline;"><span style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small; color: #000000;" face="Arial" size="2"><span style="margin: 0px; padding: 0px; border: 0px none; outline: currentcolor none 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small; color: #ff0000;" face="Arial" size="2"><span style="margin: 0px; padding: 0px; border: 0px none; outline: currentcolor none 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small;" face="Arial" size="2"><span style="margin: 0px; padding: 0px; border: 0px none; outline: currentcolor none 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small; color: #ff0000;" face="Arial" size="2">Great for storage of Covid-19 vaccines, DNA, RNA, virus samples, organs and serum</span></span></span></span></li>
<li style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline;"><span style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small; color: #000000;" face="Arial" size="2">Lock-able door, high or low temperature alarms, power failure alarm</span></li>
<li style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline;"><span style="margin: 0px; padding: 0px; border: 0px; outline: 0px; vertical-align: baseline; font-family: tahoma, arial, helvetica, sans-serif; font-size: small; color: #000000;" face="Arial" size="2">UL certified</span></li>
</ul>
<p><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #ff0000;">Important!</span></p>
<ul style="list-style: inside none square;">
<li><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #ff0000;">Do not plug in your unit. Leave your Ai refrigerator or freezer for 24 hours before turning the unit on for the first time.</span></li>
<li><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #ff0000;">This unit is NOT designed to be used on a mobile platform.</span></li>
</ul>
</div>
<p style="text-align: center;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="color: #ff0000;"><br /></span></span></span></p>
<p style="text-align: left;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><strong><span face="Arial">Specifications</span></strong></span></p>
<center>
<table style="width: 703px; height: 277px;" border="0" cols="0">
<tbody>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Model</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;E03</span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Electrical requirements<br /></span></td>
<td style="border: 1px solid #000000;">&nbsp;<span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">115V (&plusmn;10%) 60Hz 1-Phase, 90 watts <br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Temperature range</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;-10&deg;C to -25&deg;C</span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Controller</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;</span><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">Microprocessor, LED display<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Compressor</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;</span><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">Power: 110V 60Hz 1-PHASE<br />&nbsp;Cooling type: direct cooling<br />&nbsp;Defrost mode: manual<br />&nbsp;Refrigerant: CFC-free, R600a HC refrigerant<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Chamber</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Dimensions: 17 x 16 x 25" (WxDxH)<br />&nbsp;Material: coated steel<br />&nbsp;Volume: 3 Cu Ft<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Door and gasket<br /></span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Lockable door, dual sealing gaskets<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="color: #ff0000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="color: #ff0000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Working environment</span></span></span></span></span></span></span></span></span></span></span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="color: #ff0000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="color: #ff0000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;- Temperature: 10&deg;C to 32&deg;C (ideal temperature: 18&deg;C to 25&deg;C)<br />&nbsp;- Humidity: &lt;85% Rh<br />&nbsp;- Altitude: &lt; 2000 m / 6561 Ft<br />&nbsp;- Stable, well-ventilated platform with no excessive dust<br /><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;- Keep freezer at least 12 inches from any walls or ceiling<br />&nbsp;</span></span>- Use dedicated power, do not share outlet<br />&nbsp;- Extension power cable should be less than 10 feet is required<br />&nbsp;- Freezer and power outlet should be grounded properly<br />&nbsp;<span style="color: #ff0000;">- Avoid direct sunlight, water spill and do NOT use freezer outdoor<br />&nbsp;- Clean condenser fins and remove frost inside chamber at least once a month<br />&nbsp;- <span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><span style="color: #ff0000;">Important! Do not plug in your unit. Leave your Ai refrigerator or freezer for<br />&nbsp;&nbsp;&nbsp; 24 hours before turning the unit on for the first time.</span></span></span><br /></span></span></span></span></span></span></span></span></span></span></span></span></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Storage bin<br /></span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Three</span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Access port</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;One, 1" diameter, left of the freezer<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Noise level<br /></span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;27 dBA</span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Unit/shipping weight &amp; dimensions&nbsp; <br /></span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;</span><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">100 Lbs / 115 Lbs</span><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><br />&nbsp;24 x 24 x 34<span>" / 26 x 28 x 37" </span>(WxDxH)<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Safety</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Compressor over-temp protection<br />&nbsp;Compressor power surge delay protection<br />&nbsp;External door with lock<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Compliance</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;UL 61010-1<br />&nbsp;CSA C22.2<br /></span></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;Warranty</span></td>
<td style="border: 1px solid #000000;"><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;">&nbsp;One year</span></td>
</tr>
</tbody>
</table>
</center><center></center><center></center><center><center></center></center><center></center><center></center><center></center><center>&nbsp;</center><center><img alt="" src="media/E03-lh-side.jpg" /></center><center>&nbsp;</center><center><img alt="" src="media/E03-lh-open.jpg" /></center><center></center><center><img alt="" src="media/AiUL-EasyChill.gif" /></center><center></center><center><span style="font-size: small; font-family: tahoma,arial,helvetica,sans-serif; color: #000000;"><strong><span>Standard Package<br /><br /></span></strong></span></center><center>
<table style="width: 602px; height: 1px;" border="0" cols="0">
<tbody>
<tr>
<td style="border: 1px solid #000000; text-align: center;">
<p><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;"><strong>Part description</strong></span></span></span><br /></span></span></p>
</td>
<td style="border: 1px solid #000000; text-align: center;">
<p><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;">&nbsp;<span style="font-size: small;"><strong>Quantity<br /></strong></span></span></span></p>
</td>
<td style="border: 1px solid #000000; text-align: center;">
<p><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;"><strong>Part image</strong></span></span></span></p>
</td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">&nbsp;Ai E03 -25&deg;C freezer</span><br /></span></span></td>
<td style="text-align: center; border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">1 pc</span><br /></span></span></td>
<td style="border: 1px solid #000000;">
<p style="text-align: center;">&nbsp;<img alt="" height="66" src="media/E03-lh-close.jpg" width="50" /></p>
</td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">&nbsp;Plastic storage bin</span></span></span></td>
<td style="text-align: center; border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">3 pcs</span></span></span></td>
<td style="border: 1px solid #000000; text-align: center;"><img alt="" height="50" src="media/Freezer-drawer.jpg" width="70" /></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">&nbsp;Ice scraper</span></span></span></td>
<td style="text-align: center; border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">1 pc</span></span></span>&nbsp;</td>
<td style="border: 1px solid #000000;">
<p style="text-align: center;"><img alt="" height="54" src="media/IceScraper-white.jpg" width="100" /></p>
</td>
</tr>
<tr>
<td style="border: 1px solid #000000;">&nbsp;<span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">Door key</span></span></span></td>
<td style="text-align: center; border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">2 pcs</span></span></span></td>
<td style="border: 1px solid #000000; text-align: center;"><img alt="" height="50" src="media/G27-Keys.jpg" width="50" /></td>
</tr>
<tr>
<td style="border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">&nbsp;User's manual</span></span></span></td>
<td style="text-align: center; border: 1px solid #000000;"><span style="font-family: tahoma,arial,helvetica,sans-serif;"><span style="color: #000000;"><span style="font-size: small;">1 pc</span><br /></span></span></td>
<td style="border: 1px solid #000000;">
<p style="text-align: center;"><img alt="" height="55" src="media/user-manual.jpg" width="78" /></p>
</td>
</tr>
</tbody>
</table>
</center></div>
</div>

				</div>
				<div style="clear:both"></div>
			</div>
			
			  
















<script type="text/javascript" charset="UTF-8">/*<![CDATA[*/
$(function ($) {





	var crossSellItems=[];
	
  
























  
    
    
      
      
      
    
  
  

  

  
  
  crossSellItems.push({"productLink":"<a href=\"/Ai-EasyChill-9-Cu-Ft-25C-Upright-Freezer-UL-115V-E09110.htm\">Ai EasyChill 9 Cu Ft -25°C Upright Freezer UL 115V<\/a>","imageURL":"/images/1612988671935308394813.jpg","dimensions":"width=\"38\" height=\"60\"","productPrice":"$1,990.00","rating":"","imageAltText":"Laboratory Freezers"});

  
    
    
      
      
      
    
  
  

  

  
  
  crossSellItems.push({"productLink":"<a href=\"/Ai-EasyChill-18-Cu-Ft-25C-Chest-Freezer-115V-E18c110.htm\">Ai EasyChill 18 Cu Ft -25°C Chest Freezer 115V <\/a>","imageURL":"/images/1601919021983533466060.jpg","dimensions":"width=\"60\" height=\"59\"","productPrice":"$1,990.00","rating":"","imageAltText":"Laboratory Freezers"});

  
    
    
      
      
      
    
  
  

  

  
  
  crossSellItems.push({"productLink":"<a href=\"/Ai-EasyChill-18-Cu-Ft-30C-Ultra-Low-Upright-Freezer-UL-115V-E18110.htm\">Ai EasyChill 18 Cu Ft -30°C Ultra-Low Upright Freezer UL 115V<\/a>","imageURL":"/images/16072144023471311684276.jpg","dimensions":"width=\"44\" height=\"60\"","productPrice":"$3,590.00","rating":"","imageAltText":"Laboratory Freezers"});

  
    
    
      
      
      
    
  
  

  

  
  
  crossSellItems.push({"productLink":"<a href=\"/Ai-EasyChill-29-Cu-Ft-30C-Upright-Freezer-UL-115V-230V-E29110.htm\">Ai EasyChill 29 Cu Ft -30°C Upright Freezer UL 115V/230V<\/a>","imageURL":"/images/1607574744809283482037.jpg","dimensions":"width=\"44\" height=\"60\"","productPrice":"$7,990.00","rating":"","imageAltText":"Laboratory Freezers"});

	
	$("#crossSellProducts").jcarousel({
		wrap : "circular",
		
		initCallback : QSC.apps.jCarousel.circularHelper.onInit,
		itemVisibleInCallback : {onBeforeAnimation: QSC.apps.jCarousel.circularHelper.createCarouselItem},
		itemVisibleOutCallback : {onAfterAnimation: QSC.apps.jCarousel.circularHelper.removeCarouselItem},
		itemLoadCallback : {onAfterAnimation:QSC.apps.jCarousel.circularHelper.setScroll},
		
 		//  jCarousel.circularHelper Config items below
		QSCconfig: {
			items : crossSellItems,
			template : "<table><tbody><tr><td>{productLink}</td></tr><tr><td class='label'>{productLink}</td></tr><tr><td class='price'>{productPrice}{rating}</td></tr></tbody></table>"
		}
	});
    

	
});
/*]]>*/</script>

    
	    
	    
			
	    
    
    <div class="upsell clearfix">
		
		
			<h3 class="upsell-header">Related Items</h3>
			<ul id="crossSellProducts" class="multiple-jcarousels jcarousel-skin-tango">
			</ul>
		
	</div>


			
		
		
		
		
		
        
	
	








	<div class="product-reviews loading" id="productReviews">
		<div class="title-bar">
			<span class="review-main-title">
				Reviews
			</span>
			<span class="review-main-count">
				(0)
			</span>
			<a href="javascript:void(0)" onclick="QSC.page.current().getRatingsReviews().writeReview()">Write a Review</a>
		</div>
		<div class="review-loading">
			<div></div>
		</div>
		<div id="productReviewsDynamic">
		
			<div class="review-no-results">
				No Reviews.  <a href="javascript:void(0)" onclick="QSC.page.current().getRatingsReviews().writeReview()">Write a Review</a>
			</div>
		
		</div>
	</div>
	
	<script id="ui-dialog-reviewDialog" type="text/html"><div class="qsc-ui-dialog" style="width:550px">

		<form action="productReviewSubmit.sc" method="POST">
			<input type="hidden" name="productId" value="1426" />
			
			<div class="form-required-key">* Required</div>
						
			<div class="form-label">Rating:<span class="form-required">*</span></div><div class="form-input clear-fix" >
				<input type="hidden" name="rating" value="" />
				<div class="rating-selector clearfix" id="rating-selector">
					<div class="rating rating-5" onclick="QSC.page.current().getRatingsReviews().toggleRating(this,5)"></div>
					<div class="rating rating-4" onclick="QSC.page.current().getRatingsReviews().toggleRating(this,4)"></div>
					<div class="rating rating-3" onclick="QSC.page.current().getRatingsReviews().toggleRating(this,3)"></div>
					<div class="rating rating-2" onclick="QSC.page.current().getRatingsReviews().toggleRating(this,2)"></div>
					<div class="rating rating-1" onclick="QSC.page.current().getRatingsReviews().toggleRating(this,1)"></div>
				</div>
			</div>
			
						
			<div class="form-label">Title:<span class="form-required">*</span></div><div class="form-input clear-fix" >
				<input name="title" type="text" maxlength="80"/>
			</div>
			
						
			<div class="form-label">Comments:<span class="form-required">*</span></div><div class="form-input clear-fix" >
				<textarea name="content" rows="5" cols="100" id="reviewDialogContent"></textarea>
				<span class="review-countdown"><span id="reviewDialogCountdown"></span> characters remaining</span>
			</div>
		
		</form>
	
	</div></script>
	

</div>

            </div>
          
          
        
      
    </div>
  


				</div>
			</div>
			<!-- /sf_main_wrapper -->
		</div>
		<!-- /sf_main -->
		<div class="sf_extra12"><span></span></div>
		<div class="sf_region7">
			













  
    <div class="widgetset_app3_0 widgetset">
      
        
          
          
             
            












	




	










  
  







<div class="widget shopping-cart-widget">
  <h3 class="widget_header"><span><a href="viewcart.sc">Shopping cart (0)</a></span></h3>

    <div class="widget_content">
  
    Shopping cart is currently empty.
    
  
    </div>

</div>


          
        
      
        
          
          
             
            












	




	












  
    
    
  











  
	<div class="widget category-tracker">
      <h3 class="widget_header"><span><a href="/main.sc">Product lines</a></span></h3>
		<div class="widget_content">
  
  
		



  <ul class="cat">
    
      
      
      
      <li class="sf_first_cat">
        <a href="/Chillers-Heaters_c173.htm" class="">Chillers &amp; Heaters</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Cold-Traps_c188.htm" class="">Cold Traps</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Distillation_c215.htm" class="">Distillation</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Freezers_c185.htm" class="">Freezers</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Lab-Equipment_c243.htm" class="">Lab Equipment</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Medical-Equipment_c219.htm" class="">Medical Equipment</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Ovens_c15.htm" class="">Ovens</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Reactors_c162.htm" class="">Reactors</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Rotary-Evaporators_c156.htm" class="">Rotary Evaporators</a>
        
      </li>
    
      
      
      
      <li class="">
        <a href="/Refurbs-Sale_c232.htm" class="">Refurbs &amp; Sale</a>
        
      </li>
    
      
      
      
      <li class="sf_last_cat">
        <a href="/Vacuum-Pumps_c166.htm" class="">Vacuum Pumps</a>
        
      </li>
    
  </ul>



  
      </div>
    </div>
  
  



          
        
      
        
          
          
             
            












	




	











  
    <div class="widget custom-html custom-html-1">
      
        <h3 class="widget_header"><span>Have a question?</span></h3>
      	
      <div class="widget_content">
        








<div class="qsc-html-content">
<p style="text-align: center;"><img alt="" src="media/TalkToLivePerson2A.jpg" /></p>
</div>
      </div>
    </div>
  
  



          
        
      
        
          
          
             
            












	




	











  
    <div class="widget custom-html custom-html-2">
      
        <h3 class="widget_header"><span>Meet Ai</span></h3>
      	
      <div class="widget_content">
        








<div class="qsc-html-content">
<table align="center" border="0">
<tbody>
<tr>
<td style="text-align: center;"><a href="https://www.acrossinternational.com/contactus.sc#RequestQuote" target="_blank"><img alt="" height="92" src="media/icon_requestQuote1.jpg" width="100" /><br /></a></td>
</tr>
<tr>
<td style="text-align: center;"><br />&nbsp; <a href="https://icalcpayment.com/Default.aspx?primary=8266549d-f626-45e7-8b08-c6084344359d" target="_blank"><br /></a><a href="https://icalcpayment.com/Default.aspx?primary=8266549d-f626-45e7-8b08-c6084344359d" target="_blank"><br /><img alt="" src="media/Ascentium.gif" /><br /></a><br />&nbsp;</td>
</tr>
<tr>
<td style="text-align: center;">&nbsp;<br /><a href="https://www.acrossinternational.com/contactus.sc#RequestQuote" target="_blank"><img alt="" src="media/bulkorder(3).jpg" /></a><br /><a href="https://www.acrossinternational.com/contactus.sc" target="_blank">Bulk Orders</a><br />&nbsp;</td>
</tr>
<tr>
<td style="text-align: center;">&nbsp;<br /><a href="https://www.acrossinternational.com/contactus.sc#RequestQuote" target="_blank"><img alt="" src="media/customdesign.jpg" /></a><br /><a href="https://www.acrossinternational.com/contactus.sc" target="_blank">Custom Service</a>&nbsp;</td>
</tr>
<tr>
<td style="text-align: center;"><br />&nbsp;<a href="https://pittcon.org/excellence-award-winners/" target="_blank"><img alt="" src="media/PittConTrophy.jpg" /></a><br /><a href="https://pittcon.org/excellence-award-winners/" target="_blank">Ai is PittCon 2020 Silver Innovation Award Winner</a><br />&nbsp;</td>
</tr>
<tr>
<td style="text-align: center;">&nbsp;<br /><a href="https://pittcon.org/pittcon-2019/" target="_blank"><img alt="" src="media/Pittcon2019MiniBanner.gif" /></a><br /><a href="https://pittcon.org/register/" target="_blank">PITTCON 2019, 03/17-21 2019, Philadelphia, PA USA</a><br />&nbsp;</td>
</tr>
<tr>
<td style="text-align: center;">&nbsp;<br /><a href="http://www.matscitech.org/" target="_blank"><img alt="" src="media/MSnT2019MiniBanner.gif" /><br />Materials Science &amp; Technology Sep 29 - Oct 3, 2019. Oregon Convention Center Portland, Oregon USA</a><br /><br /></td>
</tr>
<tr>
<td style="text-align: center;">&nbsp;<br /><a href="https://advancedceramics.org/events/2018/05/01/other-industry-events/ceramics-2018-expo/" target="_blank"><img alt="" src="media/USACAtradeshowad.gif" /><br />Ceramics 2018 Expo, 5/1 - 5/3, 2018, Cleveland, OH</a><br /><br /></td>
</tr>
<tr>
<td style="text-align: center;">&nbsp;<br /><a href="https://www.avs.org/symposium" target="_blank"><img alt="" src="media/AVStradeshowad.gif" /><br />AVS 65th International Symposium &amp; Exhibition 2018, 10/21-10/26, Long Beach, CA.</a><br /><br /></td>
</tr>
<tr>
<td style="text-align: center;">&nbsp;<br /><a href="https://www.mrs.org/fall2018" target="_blank"><img alt="" src="media/MSRFalltradeshowad.gif" /><br />MRS SPRING 2018 - Fall, 11/25-11/30, BOSTON, MA </a><br /><br /></td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
</div>
      </div>
    </div>
  
  



          
        
      
    </div>
  


		</div>
		<div class="sf_region8">
			














		</div>
		<!-- 7 -->
		<div class="sf_extra7"><span></span></div>
		<div class="sf_region9">
			













  
    <div class="sf_footer">
      
        
          
          
             
            












	




	





	
	
		
		
	


<div class="navigation2 fcontain">
	
		
		
		<span class="sf_first_nav_item">
			<a href="/aboutus.sc" 
                  >About Us</a>
		</span>&nbsp;
	
		
		
		<span class="">
			<a href="/contactus.sc" 
                  >Contact Us</a>
		</span>&nbsp;
	
		
		
		<span class="">
			<a href="/sitemap.htm" 
                  >Site Map</a>
		</span>&nbsp;
	
		
		
		<span class="">
			<a href="/login.sc" 
                  >Sign In</a>
		</span>&nbsp;
	
		
		
		<span class="">
			<a href="/register.sc" 
                  >Register</a>
		</span>&nbsp;
	
		
		
		<span class="">
			<a href="/termsandconditions.sc" 
                  >Terms and Conditions</a>
		</span>&nbsp;
	
		
		
		<span class="">
			<a href="https://www.acrossinternational.com/contactus.sc#RequestQuote" 
                  >Request a Quote</a>
		</span>&nbsp;
	
		
		
		<span class="">
			<a href="/viewcart.sc" 
                  >Shopping Cart</a>
		</span>&nbsp;
	
		
		
		<span class="sf_last_nav_item">
			<a href="https://acrossinternational.com/termsandconditions.sc#private" 
                  >Privacy Policy</a>
		</span>&nbsp;
	
</div>

          
        
      
        
          
          
             
            












	




	








<div class="footer">
	








<br /><br />Across International LLC<br />
111 Dorsa Ave<br />
Livingston, NJ 07039-1002<br />
United States<br /><br />

<span class="qsc-site-company-copyright">Copyright &copy; 2008-2021 Across International. All rights reserved.</span>

<script type="text/javascript">
piAId = '533972';
piCId = '45372';
piHostname = 'pi.pardot.com';

(function() {
	function async_load(){
		var s = document.createElement('script'); s.type = 'text/javascript';
		s.src = ('https:' == document.location.protocol ? 'https://pi' : 'http://cdn') + '.pardot.com/pd.js';
		var c = document.getElementsByTagName('script')[0]; c.parentNode.insertBefore(s, c);
	}
	if(window.attachEvent) { window.attachEvent('onload', async_load); }
	else { window.addEventListener('load', async_load, false); }
})();
</script>

</div>


          
        
      
    </div>
  


		</div>
		<div class="sf_extra8"><span></span></div>
	</div>
	<!-- /sf_wrapper -->
	<div class="sf_extra9"><span></span></div>
</div>
<!-- /sf_outer_wrapper -->
<div class="sf_region10">
	













  
    <div class="sf_banner">
      
        
          
          
             
            












	




	






<div id="paymentlogos">
	
		<img style="border:1px solid transparent;" src='/static/images/common/paypal_logo_50x34.gif' alt='PayPal'/>	
	
	
		<img src='/static/images/common/visa_card.gif' alt='VISA'/>	
	
	
		<img src='/static/images/common/master_card.gif' alt='MasterCard'/>	
	
	
		<img src='/static/images/common/discover_card.gif' alt='Discover'/>	
	
	
		<img src='/static/images/common/am_ex.gif' alt='American Express'/>	
	
	
	
	
	
	
    
</div>
<div id="disclaimers">
  
</div>


          
        
      
        
          
          
             
            












	




	









<div id="seals">
	
		<div id="siteseal">
			<ul id="seal">
				<li>
					<script charset="UTF-8" src="https://seal.godaddy.com/getSeal?sealID=sHoSmdY9L2zG31CxhGQGeZbZd5BRsvY3sGZd4cv74tk3dYJ4TY7Np" type="text/javascript"></script>
					<br/>
					
				</li>
			</ul>
		</div>
	
	
	
</div>


          
        
      
    </div>
  


</div>





		
	
	
	
	





	
<script type="text/javascript" src="/static/scripts/pages/sf.desktop.product.js?v=20201214-105212"></script>



<script type="text/javascript">
	QSC.page.load("storefront.product",{"iProductId":1426,"images":[{"thumbnail":{"url":"/images/1612992459966-490110227.jpeg","width":80,"height":77},"preview":{"url":"/images/1612992460917-35386614.jpeg","width":175,"height":168},"fullsize":{"url":"/images/E03-lh-open.jpg","width":568,"height":547}},{"thumbnail":{"url":"/images/161299245903657624668.jpeg","width":60,"height":80},"preview":{"url":"/images/16129924595511832167086.jpeg","width":132,"height":175},"fullsize":{"url":"/images/E03-lh-close.jpg","width":394,"height":521}},{"thumbnail":{"url":"/images/1612992458354-1044603757.jpeg","width":71,"height":80},"preview":{"url":"/images/16129924585921988385869.jpeg","width":155,"height":175},"fullsize":{"url":"/images/E03-lh-side.jpg","width":486,"height":546}},{"thumbnail":{"url":"/images/1610719905999-1480160489.gif","width":57,"height":80},"preview":{"url":"/images/16107199056751877330375.gif","width":125,"height":175},"fullsize":{"url":"/images/AiUL-EasyChill.gif","width":690,"height":965}}],"bHasOptions":"true","options":{"id":1426,"bAutoPick":false,"price":"1590.00","optionsList":[{"optionId":108,"optionLabel":"Delivery liftgate service","optionType":"DROPDOWN","optionPriceInc":"0.00","optionRequired":true,"configurable":false,"valueMap":[{"id":1072,"value":"I do not need liftgate service","priceAdj":"0.00","text":"I do not need liftgate service"},{"id":1073,"value":"Yes I need liftgate service","priceAdj":"35.00","text":"Yes I need liftgate service (+$35.00)"}]}],"availMap":{"default":{"status":"In-Stock"},"items":[]}},"bShowRatingReviews":true});
</script>

</body>



</html>